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Overview

Overview

BorderLiner provides a simple method to draw borders in tables and some text elements in
OpenOffice.org Calc and Writer.

Define the border style in a dialog or pick it from an existing cell, select the cell(s) or text elements
and assign the border with some key strokes.

Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0
(the "License"); you may only use this Documentation if you comply with the terms of this License.
A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is "BorderLiner". The Initial Writer(s) of the Original Documentation
is Dietmar Hiller© 2006-2007. All Rights Reserved. (Initial Writer contact(s): hillerd@tiscali.de.)

Contributor(s): ______________________________________. 

Portions created by ______ are Copyright (C)_________[insert year(s)]. All Rights Reserved.
(Contributor contact(s):________________[insert hyperlink/alias]).

All trademarks within this guide belong to legitimate owners.

[Note: a copy of the PDL is included in this template and is also available at:

http://www.openoffice.org/licenses/PDL.rtf.]

The herein described extension BorderLiner is subject to the GNU Lesser General Public License
(LGPL). A copy of the LGPL is available at http://www.gnu.org/licenses/lgpl.html.

Feedback

Suggestions for improvement of the macro and the documentation are more than welcome! 

Please contact me at

my user-ID hillerd in Germany (.de) at tiscali 

The released macro BorderLiner is available at http://ooomacros.org  .  

Intermediate development steps can be downloaded from
http://home.cablesurf.de/dhiller > Various > Software

This extension is free of charge to you. Nevertheless, to satisfy my curiosity I would be glad to
receive a post-card of your home town, if you like and use this extension. 
My postal address is: Dietmar Hiller, Dom-Pedro-Str. 22, 80637 Muenchen, Germany. 
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Overview

Modifications and updates

Version Date Description of Change

0.1 05-Aug-06 Initial edition issued with basic functionality

0.2 22-Aug-06 Added dialog to set line style
Added option to set borders for entire table or for each cell
Improved border functionality 
Improved installation creates toolbar with button

1.0 26-Sept-06 Added drawing capabilities to text tables and other text elements
Improved installer (requires OOo 2.0.3 or later)
Added feature to pick line style

The macro now terminates when the document is closed

1.1 16-Dec-06 Added using with hidden dialog
Memorizes dialog position

1.2 08-Feb-07 Allow multiple selections in CALC sheets

1.3 10-Mar-07 Providing a selection of line styles with preview
Exchange color model of RGB with HSL, which is more intuitive.

1.3.1 25-Apr-07 Bugfix for OpenOffice.org 2.2 distributed with Ubuntu 7.04

Installation

Requirements

This macro was developed and tested on Linux Ubuntu 6.10 with OpenOffice.org 2.2. It was also
tried on Windows XP/SP2 and OpenOffice.org 2.0.4.

It will also run under younger versions of OpenOffice.org 2.0.x (without some cosmetic features).
You might need to rename BorderLiner.oxt to BorderLiner.zip (it was reported that version 1.3
worked this way under 2.0.2). Whether it runs under OpenOffice.org 1.x is unknown to me.

Desktop

Together with this documentation, you will have received the installation file BorderLiner.oxt. It
may be packed in a zip-file. Copy BorderLiner.oxt into a temporary folder, it will be used for
installation with the Package Manager. 

For installation, start OpenOffice.org and go to the menu item Tools > Package Manger. Select

My Packages and Add BorderLiner.oxt.

If you upgrade the macro from a previous version, you will receive a warning. This warning is
positioned behind the window of the Extension Manager, so that you have to move that to the side
in order to confirm overwriting. 

You will find a new toolbar BorderLiner in View > Toolbars with a button to call this macro in

your applications Calc and Writer. If the toolbar is not available, please close and restart
OpenOffice.org.

If you prefer to place the macro in another toolbar, create a new toolbar with the menu item View >

Toolbars > Customize > Toolbars > New. In this toolbar the macro can now be added with Add >

OpenOffice.org Macros > My Macros > BorderLiner > Main > Main. The macro is now called

Main, to rename it use Modify > Rename. To set the icon use again Modify > Change Icon >

Import. Go to the directory where the macro is installed (use the explorer search function to find
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Installation

the file BorderLiner_16.bmp – e.g. in Windows in Documents and Settings). Set the type to BMP

and select the icon. Find this icon in the gallery and close the actions with OK.

Portable OpenOffice.org

The Package Manager might not work in portable OpenOffice.org. But there is the possibility to
install the macro manually.

Copy the directory BorderLiner from BorderLiner.oxt in the directory \PortableOpenOffice

\settings \user \basic.

The following files in \PortableOpenOffice\settings\user\basic have to be edited manually. Add the
following lines directly above the line  "</library:libraries>".

dialog.xlc:

 <library:library library:name="BorderLiner"
xlink:href="$(USER)/basic/BorderLiner/dialog.xlb/" xlink:type="simple"
library:link="false"/>

script.xls:

 <library:library library:name="BorderLiner"
xlink:href="$(USER)/basic/BorderLiner/script.xlb/" xlink:type="simple"
library:link="false"/>

You can now call the macro via the menu item Tools > Macro > Run Macro. You might get an
error message about the Java Runtime Engine (JRE). As long as your PC has JRE installed, the

message can be ignored. Start the macro with My Macros > BorderLiner > Main > Main.

To assign the macro to a toolbar follow the instructions above.
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Usage

Usage

Defining the line style

Click on the icon  of the toolbar to start the dialog to set the line styles.

The following settings can be done:

� Linestyle

A selection of 17 predefined line styles is available. These are also the only line styles
available in text tables (see also "known issues"). 

Linestyle Number

0

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17
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Usage

� Color: hue, saturation, illumination

Defines the color of the line. The color is shown in the adjacent bar.
Hue defines the basic color. The lower the saturation of a color, the more "grayness" is
present and the more faded the color will appear. Reducing the illumination darkens the
color.
For gray colors (including black and white), set the saturation to 0 and adjust the brightness.
Hue has no significance here.

� apply to:

Element - applies the line to each selected element
Table - applies the line to the entire table
 see below for details

� Hide

Checking this box hides the dialog immediately. This comes very handy, if you only intend
to pick and draw lines from the keyboard. Use the "0" key to toggle dialog visibility.

� Pick

Check this box to pick the line style from the document. This enables easy setting of the
same border style to a series of objects.

� Done

The macro is terminated by clicking on Done or by pressing the ESC key while drawing.

The settings of the dialog are kept as long as OpenOffice.org is running. When you re-open the
dialog, the previous settings are shown again. Also the position of the dialog is preserved during the

entire OpenOffice.org session.

BorderLiner 6



Usage

Drawing the borders

After having defined the line style in the dialog, select the table or the element you want to apply
this border to.

Also the status line shows that the macro is active: 

With the following key strokes the lines are drawn:

       

Always 2, 4, 6 and 8 draw the bottom, left, right and top line. For tables 7 draws the horizontal lines

and 9 the vertical lines inside the table, whereas for elements 1 and 3 draw diagonal lines in Calc
cells. An underlying numeric keypad is shown to ease memorizing the key strokes.

Deleting a line can be done by holding the Shift key and pressing the corresponding key. Also
setting the line style to 0 in the dialog is possible.

In OpenOffice.org the borderline belongs to a cell and not to the border between the two
adjacent cells. This means that a line that was drawn as a bottom line of one cell cannot be
cleared by removing the top line of the cell below.

If a feature is not available (e.g. diagonal line in tables), a sound is played.
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Usage

While the macro is running, the application can be used as usual. Only the keys 0 to 9 are
not available.

The macro is terminated by pressing the ESC key in the document or by hitting the Done button.

Picking a line style

It is possible to read the border line style from existing cells if you want to apply the same borders
to other cells.

Mark the Pick checkbox in the dialog and then press the number key (e.g. "2" for bottom line) in
the cell whose line style you want to copy. The border settings are read to the dialog. The Pick
checkbox is cleared automatically so that you can apply the same border style to other cells
immediately. CTRL-2 would do the same job.

The same keystrokes as for drawing a borderline are also valid here.

Because the borderline belongs to a cell and not to the border between the two adjacent cells, a
line that was drawn as a bottom line of one cell could be different to the top line of the cell
below. Only one of the two is displayed and picked.
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Usage

Where the borders can be drawn

The toolbar is only available in Writer and in Calc.

Calc

An Element in Calc is the individual cell, whereas the Table is the entire selection. Therefore, with
apply to set to Element, e.g. a bottom line would be drawn to each cell of the selection in Image
5, whereas if set to Table, only the cells CK383:CP383 and CK396:CP396 would have a bottom
line drawn.

This example also shows that the selection of non-adjacent cells is possible.

Image 5: Drawing borders in Calc (example taken from http://stats.openoffice.org/spreadsheet/index.html)

Writer

In Writer, selecting a range of cells and choosing Elements, assigns the borderline to that range,
not to each cell of the range. So the behavior is identical to choosing Table in Calc.

Table marks the entire table, the cursor is in, independent of the selection.

2006-07-08 2006-07-15 2006-07-22

49.684 35.045 31.271

15.061 13.106 13.997

Image 6: Drawing borders in Writer tables

The black borders where drawn by placing the cursor in the table and applying the keystrokes to the
table. The blue lines were created by selecting the first raw of the table and applying the keystrokes
to the elements.
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Usage

Additionally to Writer tables, borders can also be drawn to other elements:

to simple paragraphs

Make sure to set some space below the paragraph in the format menu, otherwise the line might
not be visible.

to frames

Image 7: to picture objects

Impress and Draw

Because tables in Impress and Draw are Calc objects, BorderLiner also works on tables in these
applications.

BorderLiner does not work on text frames in Draw and Impress. These frames are drawing-objects
and the borderline is realized with a different feature.

What's next?

� Known issues currently under investigation

� A bug was observed when using BorderLiner over various Calc sheets: the keylistener
was not terminated properly after ending the macro. Workaround: close and restart
OpenOffice.org.

� If the application is closed while the macro is running, OpenOffice.org crashes after
having closed all files. Closing just the document while the macro is running causes no

problem. Best practice is to terminate the macro before closing the application.

� In Writer the borderline is currently applied to the cell range when Elements is selected
not to each cell in.

� Version 2.0:

� substitution of dialog with enhanced features of the toolbar

� Version "later": 

� Drawing with mouse instead of or additional to keys
Note: mouse pointer cannot be set to pencil (missing OOo feature)

� Know issues that cannot or are not planned to be resolved

� OpenOffice.org uses only those line widths and distances in text tables as they are
predefined in BorderLiner; other settings would get lost after saving. See also the issue
"[Issue 69608] Writer table double borders assigned by macro are lost after saving"
(http://www.openoffice.org/issues/show_bug.cgi?id=69608). Current OOo target
milestone is 2.x.
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What's next?

� In double lines, the top line shows in Writer the one in the internal part of the cell,
whereas it is the top or left one in Calc. See also issue
"http://www.openoffice.org/issues/show_bug.cgi?id=74826".
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